llgd.net
当前位置:首页 >> tomCAt7支持jDk1.8吗 >>

tomCAt7支持jDk1.8吗

你说反了,而应该问jdk1.8支持tomcat7吗?tomcat底层运行的就是java的Socket,也就是说tomcat是在jdk环境下运行的。而且这也不是问题,tomcat本来就是用java语言写的,java版本高1.8肯定支持tomcat7了,好像tomcat7在某个版本(7.0.72,具体记不...

支持,看看你的类是不是在1.7的java环境编译的,还有看看你的tomcat使用的jre是不是1.8的,是不是装了多个不同版本的jre,可能是tomcat引入的jre和jdk的不一样

支持,看看你的类是不是在1.7的java环境编译的,还有看看你的tomcat使用的jre是不是1.8的,是不是装了多个不同版本的jre,可能是tomcat引入的jre和jdk的不一样

支持,看看你的类是不是在1.7的java环境编译的,还有看看你的tomcat使用的jre是不是1.8的,是不是装了多个不同版本的jre,可能是tomcat引入的jre和jdk的不一样

支持,但是你用这么高版本做什么,高版本可能会舍弃一部分旧特性,导致编译时出现莫名其妙的错误,还是推荐tomcat6.0+jdk1.6

支持"、、、

不呀,我就是jdk1.8,tomcat7,

比如tomcat7,对应的jdk就是1.7。tomcat8,对应的就是jdk1.8 依次类推支持的

支持,看看你的类是不是在1.7的java环境编译的, 还有看看你的tomcat使用的jre是不是1.8的, 是不是装了多个不同版本的jre, 可能是tomcat引入的jre和jdk的不一样

从官方版本说明来看,jdk1.8跟Tomcat 7应该是兼容的,如图: 原链接:http://tomcat.apache.org/whichversion.html

网站首页 | 网站地图
All rights reserved Powered by www.llgd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com