llgd.net
当前位置:首页 >> kAFkA 0.9 配置 >>

kAFkA 0.9 配置

因为0.9 之后的kafka使用了新的consumer API进行消费,配置bootstrap-server。旧API虽然兼容,但是会被逐渐取代。 参照官方文档 2.2 Consumer API As of the 0.9.0 release we have added a new Java consumer to replace our existing high-lev...

Kafka是由LinkedIn设计的一个高吞吐量、分布式、基于发布订阅模式的消息系统,使用Scala编写,它以可水平扩展、可靠性、异步通信和高吞吐率等特性而被广泛使用。目前越来越多的开源分布式处理系统都支持与Kafka集成,其中Spark Streaming作为后...

答:这个是scala的编译库喝运行时库(kafka是用sbt管理依赖的),所以建议你使用sbt,会自动下载所有依赖

因为0.9 之后的kafka使用了新的consumer API进行消费,配置bootstrap-serve

答:这个是scala的编译库喝运行时库(kafka是用sbt管理依赖的),所以建议你使用sbt,会自动下载所有依赖

网站首页 | 网站地图
All rights reserved Powered by www.llgd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com