llgd.net
当前位置:首页 >> 如何解决M2Crypto不支持python3的问题 >>

如何解决M2Crypto不支持python3的问题

取决于你的项目需要 M2Crypto 的具体什么功能,可以选择的替代品包括但不限于:cryptography, pycrypto, pyopenssl, passlib。我列出的这几个都支持 Python 3.x。

此教程为官方wiki补充,并附带M2Crypto、gevent 安装的详细说明,以便于零基础用户配置 shadowsocks 服务端。 此处以bandwagonhost的廉价VPS举例… 系统 CentOS6.5 x86,内建Python版本2.6.6(可使用 python -V 命令查看) 准备工作:安装所需组件 ...

windows 的可以试试 https://github.com/saltstack/salt-windows-install/blob/master/deps/win32-py2.7/M2Crypto-0.21.1.win32-py2.7.msi

根据scrapy的文档,现在开发人员正在向python3迁移,也就是说目前只能完全支持python2。因此,解决方案有三个: 用python2 等待scrapy迁移完 不用python3不支持的特性

pycrypto模块好像是用命令python setup.py install安装 打开命令提示符,切换到解压后的crypto模块文件夹,输入命令 C:\python33\python setup.py install 回车 安装模块

系统 CentOS6.5 x86,内建Python版本2.6.6(可使用 python -V 命令查看) 准备工作:安装所需组件 yum install wget tar gcc gcc-c++ openssl openssl-devel pcre-devel python-devel libevent -y 一、升级python 1、按以下步骤执行 cd /root wget...

使用from Crypto.Cipher import AES导入后,就可以直接使用了,不需要再加前缀:Crypto.Cipher.xxx 直接使用即可

系统 CentOS6.5 x86,内建Python版本2.6.6(可使用 python -V 命令查看) 准备工作:安装所需组件 yum install wget tar gcc gcc-c++ openssl openssl-devel pcre-devel python-devel libevent -y 一、升级python 1、按以下步骤执行 cd /root wget...

其实 pip 和easy_install 都是安装python插件用的,你可以用 easy_install install shadownsocks 来安装的

此教程为官方wiki补充,并附带M2Crypto、gevent 安装的详细说明,以便于零基础用户配置 shadowsocks 服务端。 此处以bandwagonhost的廉价VPS举例… 系统 CentOS6.5 x86,内建Python版本2.6.6(可使用 python -V 命令查看) 准备工作

网站首页 | 网站地图
All rights reserved Powered by www.llgd.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com